Follow

if you pin the dependencies on your npm package to "^x.x.x", so you never allow updates to minor versions, only patch versions, I hate you.

@Floppy Hmm, I don't think that what ^ does.

semver.npmjs.com/ says ^1.2.3 will match v1.2.3, v1.2.4, and v1.3.0 (but not v2.x.x). Maybe you hate ~x.x.x?

(Totally agree that pinning to a minor version is the purest evil either way)

@pimterry yeah, I think you're right there. Something in that area is causing me problems though :)

Sign in to participate in the conversation
Open social media for the UK

A social media community hosted in the UK; part of the Mastodon/ActivityPub federated social network, which allows you to follow users on other communities. It's a bit like Twitter but without a single company in control.

If you use this server, you are required to abide by our Code of Conduct. If you don't like it, there are plenty of other communities you can use.

If you're coming here from Twitter, there are some very useful services to help you find friends and automatically crosspost toots that you might like to set up once you're signed in.

Backers

This is a volunteer-run community administered by @floppy, and hosted by Mastohost in the UK. Please support our running costs by joining the Open Collective and becoming a backer. Thanks go to our existing backers - this place exists because of them!

Service status is available from our status page and the @status account.